Go Back   :::.Nissan 4x4 Owners Club.::: > General > I'm new here, please be gentle

I'm new here, please be gentle This is where you can "introduce yourself". A chance for you as a new member to say hello and for you to tell us about yourselves, your truck and your other interests.

Reply
 
Thread Tools Display Modes
Old 28-11-2020, 22:36   #1
Fredo
Junior Member
Click here to find out how to become a paid up member
 
Join Date: Nov 2020
Location: Wales
Vehicle: Terrano 2
Posts: 3
Default Terrano 2.7 off-roader build

Hi gents new on here i am a beef farmer in south Pembrokeshire got a terrano to use around the farm teach the kids to drive and have some fun in
bought one ,guy told me it needed a new water pump got it home on trailer put water in started her up water going straight out the exhaust suspect head gasket ? But no water in oil could it be something else before it gets stripped ie inlet manifold gasket / water pump or core plug somewhere need a bit of sound advice from you experts please
Fredo is offline   Reply With Quote
Old 29-11-2020, 09:15   #2
elty001
Senior Member
Click here to find out how to become a paid up member
 
elty001's Avatar
 
Join Date: Feb 2008
Location: Aflreton,Derbyshire.
Vehicle: 2000se+ 2.7tdi terrano II
Posts: 6,575
Default

When the water pump lets go on the 2.7 it leaks from the front of the engine.
Is there oil in the coolant??
__________________
2000 terrano II se+ auto 2.7tdi.3"spring lift.2"body lift.33 12.50 15 nankang muds on steel rims.snorkel.wind deflectors.cb.led light bar,30mm nutcentric wheel spacers.pro comp steering damper,12000lb front winch,rose jointed ARB,super strong steering idler,custom steel rear bumper and man steps
elty001 is offline   Reply With Quote
Old 29-11-2020, 13:12   #3
Fredo
Junior Member
Click here to find out how to become a paid up member
 
Join Date: Nov 2020
Location: Wales
Vehicle: Terrano 2
Posts: 3
Default

Hi 001 thanks for your advice doesnít have any water in oil or coolant but coolant only takes a few minutes to pass out of exhaust pipe cheers 👍
Fredo is offline   Reply With Quote
Old 29-11-2020, 18:21   #4
elty001
Senior Member
Click here to find out how to become a paid up member
 
elty001's Avatar
 
Join Date: Feb 2008
Location: Aflreton,Derbyshire.
Vehicle: 2000se+ 2.7tdi terrano II
Posts: 6,575
Default

Sure there is a coolant feed to the turbo so might be a problem in that area.
Is it smoking or running rough??
__________________
2000 terrano II se+ auto 2.7tdi.3"spring lift.2"body lift.33 12.50 15 nankang muds on steel rims.snorkel.wind deflectors.cb.led light bar,30mm nutcentric wheel spacers.pro comp steering damper,12000lb front winch,rose jointed ARB,super strong steering idler,custom steel rear bumper and man steps
elty001 is offline   Reply With Quote
Old 29-11-2020, 19:40   #5
Fredo
Junior Member
Click here to find out how to become a paid up member
 
Join Date: Nov 2020
Location: Wales
Vehicle: Terrano 2
Posts: 3
Default

Hi 001 itís a bit sluggish to start but when running has plenty of power job to know about smoking as itís steamy stuff out exhaust con only run it for a few minuets as it starts getting hot engine sounds good runs smooth. Thanks for reply 👍
Fredo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT +1. The time now is 06:23.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Images online photo albums